öffnen Tags

öffnen Kategorien

Vom WebReader vorlesen lassen

Aktualisieren von RPM

10. Jul 2009, 23:31

Als ich eben das Paket RPM updaten wollte (rpm 4.7.0-7 -> 4.7.0-8), bekam ich einen Fehler:

1
2
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)


Wer das selbe Problem hat, ich habs behoben indem ich die /var/lib/rpm/__db.001 gelöscht hab. Wer dem nicht traut kann sie auch gern erstmal verschieben, um zu sehen, dass es geht:

1
# mv /var/lib/rpm/{__db.001,xxx}

Tags: Problemlösung RPM Update

Kategorien: Problemlösung Software

© 2009-2018 by Martin Scharm